Just another problem

Cisco: Envio de rotas através de tunel – GRE + OSPF

Posted in tech by Adriano on 13/06/2008

ROUTER A – Anuncia a rota default:

!
interface Tunnel0
 description Tunnel to RouterB
 ip unnumbered Loopback0
 ip tcp adjust-mss 1436
 ip ospf 50 area 0
 tunnel source Loopback0
 tunnel destination 10.2.2.2
!
router ospf 50
 router-id 10.1.1.1
 log-adjacency-changes
 passive-interface default
 no passive-interface Tunnel0
 default-information originate
!

ROUTER B – Recebe a rota defaul via ospf:

!
interface Tunnel0
 description Tunnel to RouterB
 ip unnumbered Loopback0
 ip tcp adjust-mss 1436
 ip ospf 50 area 0
 tunnel source Loopback0
 tunnel destination 10.1.1.1
!
router ospf 50
 router-id 10.2.2.2
 log-adjacency-changes
 passive-interface default
 no passive-interface Tunnel0
 distance 1
!

Distance = 1 faz com que a rota default recebida por este processo OSPF tenha preferência sobre qualquer outro protocolo.

Não foi usado o comando ‘keepalive’ no tunel pois há o keepalive (hello packets) do ospf.

Anúncios
Tagged with: , , ,

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: